Login Issue with East Coast

Incident Report for IndySoft

Resolved

Logins in EastUS resolved
Posted Jun 24, 2026 - 13:10 EDT

Monitoring

Logins have been restored and we continue monitoring the situation.
Posted Jun 24, 2026 - 12:44 EDT

Investigating

We are currently experiencing issues with users logging into EastUS. Investigating root cause now.
Posted Jun 24, 2026 - 11:29 EDT
This incident affected: IndySoft Cloud Software (Americas).